[Samba] Samba and Cups.

Kevin Smith ksmith at perfht.com
Thu May 22 11:48:27 GMT 2003


I encountered a problem with samba (2.2.7a) when I was setting CUPS (1.1.14)
I set it up through the web interface, setting the appropriate values in



        printing = cups
        load printers = yes
        printcap name = cups

        comment = All Printers
        path = /var/spool/samba
        browseable = no
        public = yes
        guest ok = yes
        writable = no
        printable = yes
        printer admin = @sysadmin
        use client driver = yes

I used printconf-tui to set the /etc/printcap, up and it connected and
printed the windows test page perfectly.
And then it stopped. When I tried the Windows test page again it said the
printer didn't exist, so I deleted the entry and tried to re-install the
printer, but now it doesn't exist, yet it WILL still print from the CUPS web
I went to the console and types 'smbclient -L firewall' and saw all the
shares EXCEPT for the printer share. So I decided to run printconf -tui to
set it up. How did that go? Not to good.  When I attempted to print from
there it said "an error was encountered..."
So for some reason I can't seem to get the print share to activate. I've
rebooted a few times, checked the smb.conf several times, even went into
cupsd.conf and didn't find anything different. Now it WAS partially working,
by that I mean if I was having permission problems with the directories.  I
also tried setting 'printcap name = /etc/cups/printers.def, this gave me a
share called </printers> which  wouldn't connect.

Somehow, somewhere I am missing something. Why would Samba NOT set up a
share that is defined?


More information about the samba mailing list