[Samba] for what it's worth, I think I have inadvertently solved an old problem...

Barry, Christopher cbarry at infiniconsys.com
Tue May 6 20:05:05 GMT 2003

	For the longest time I was having this strange folder recursion problem. It persisted through many samba upgrades. The problem can be seen here in this thread:


I think my configuration was wrong, and as I was using security = server, it's incorrectness was not apparent. I am using MSDFS and the roots are hosted by NetBIOS aliases. I stumbled on the fix by trying to get security = domain to work. In my %L.conf files, I had a line stating the NetBIOS name of the alias, as in:

in the accounting.conf file I had:
 NetBIOS name = accounting

When I tried to get domain security to function, I could not get any of the aliased servers to authenticate. Puzzling over this, I commented out this line in the alias .conf files, and voila - I could now auth, and interestingly, the recursion problem also disappeared. Seems kinda logical now, I guess. Hopefully, this will help others pulling their hair out too.


Christopher Barry
Manager of Information Systems
InfiniCon Systems

More information about the samba mailing list