[Samba] SWAT login agony

Chee Wai Yeung cheewai_yeung2003 at yahoo.com.hk
Tue May 6 15:45:10 GMT 2003


I am not sure if this is correct but it worked on my
Samba 2.2.8a config. I think the problem is caused by
PAM on your machine. I have a file "samba" in
/etc/pam.d (honestly, I don't know why it is not
"swat"). Here is the content:

[root at notebook1 pam.d]# cat /etc/pam.d/samba
auth    required        /lib/security/pam_pwdb.so
nullok shadow
account required        /lib/security/pam_pwdb.so

With this, I got swat to allow login (use root account
to login).

Hope this helps.

Chee Wai

--- Jeremy Nix <Jeremy.Nix at sfsltd.com> wrote:
> I've installed the latest/greatest from Samba
> (3.0.alpha...).  I've been
> following the directions from this site
> (http://samba.linuxbe.org/en/samba/learn/swat.html)
> on how to set up
> SWAT for configuring Samba.  The problem I'm running
> into is logging
> into SWAT.  I've tried every user imaginable and
> still no luck.  I've
> enabled the SWAT service using xinetd, and it
> actually prompts me for a
> user/pass, but the authentication always fails.  Are
> these directions
> current?  Is there some act of god that is
> preventing me from getting
> all aspects of samba server running?
> _________________
> Jeremy Nix
> Senior Application Developer
> Southwest Financial Ltd.
> Jeremy.Nix at sfsltd.com
> (513) 621-6699 ext 1158
> --
> To unsubscribe from this list go to the following
> URL and read the
> instructions: 

Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.

More information about the samba mailing list