[Samba] WinZip causes Server to fail - Please help.......

John H Terpstra jht at samba.org
Mon Mar 24 18:08:05 GMT 2003

On Mon, 24 Mar 2003, alex wrote:

> Is anybody suffering from a similar problem or can anybody suggest a cure or
> a pointer......?

I just tried all methods of zip file creation and extractions with WinZip
6.2, 7.0, 8.0 and 8.1 without any problems. Samba version 2.2.8 (current

Tried from Windows Me and 2000 Pro and XP Pro. No problems detected.

Send me your smb.conf file (off line) to jht at samba.org - I'll check your
config over.

- John T.

> I've various hardware platforms (both HP & Intel though all SMP) scattered
> around remote sites each running one of the following OSs (Redhat 7.2,
> Redhat 7.3, Mandrake 8.2 & Mandrake 9.0) each with Samba installed (either
> the version that ships with the relative OS or or
> (downloaded and installed in the last 48 hours).
> All the servers suffer from the same issue.  That is, if a zip file is
> created, modified or extracted using WinZip 8.0 (winzip 7.0 or 8.1 don't
> appear to cause problems), then the SMB server will crucify itself.  Ping
> responces can be received, but telnet, smb or any other service offered by
> the server fails to respond.  The console is showing nothing but the login
> prompt (no GUIs are active on any of the servers, though some have X
> installed), though even this fails to respond to the keyboard.
> The only cure appears to be a hardware reboot at which point all logs get
> overwritten by the reboot process.
> Up until now, our cure has been to simply use winzip 7 (and hence avoid the
> problem), however a new package has been installed on the client
> workstations that uses an integrated version of winzip 8.
> Client workstations range from Win95 through Me to Win2kPro, XP Home/Pro &
> Win2k Server in application mode - no corrolation between client OS and the
> issue has been detected
> I appologise for the lack of real detail (full OS, SMB etc configurations
> are available if requested), but the issue appears to hitting every SMB
> server i've built regardless of OS, Samba or file system (XFS, EXT3 and EXT2
> are all represented accross the servers).  Most of the servers utilise
> integrated Promise FastTrack100 cards (Intel SCB2 UDMA motherboards),
> however others are hardware SCSI RAID based (again SCB2 motherboard with
> RAID cards (this spec includes the server that is prompting the post)).
> Others utlise AMI/LSI RAID cards.
> Various test boxes have been built using either slower (single CPU PIIs and
> dual PIII800s (IDE based)) or VMware GSX Server and none of these appear to
> exhibit the problem.  It's only the native servers running on dual PIII1000+
> hardware which suffer.
> As you can imaging, testing is a bit difficult due to it involving causing a
> live server to potentially need a hardware reboot which is something i'm not
> particularly keen on doing (suprise, suprise)
> In all other respects, each server functions perfectly in all other respects
> and certainly in respect to SMB file serving.
> Any hints, pointers or suggesions (unless they revolve around Win2k as an
> alternative file server....) will be greatfully received
> Alex
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  http://lists.samba.org/mailman/listinfo/samba

John H Terpstra
Email: jht at samba.org

More information about the samba mailing list