[Samba] even worse after another upgrade to 2.2.8!

Noel Kelly nkelly at citrusnetworks.net
Tue Mar 18 19:53:49 GMT 2003

If your log files is anything to go by it looks like you already have a
Samba process running - it cannot bind to the port as something has already
nabbed it.  Did you kill off all the old smbd processes?

Assume when you upgraded to XP you made the 'requiresignorseal' changes to
the registry?  And make sure that XP firewalling is not enabled on your LAN
interface - XP requires a response from the server when printing which the
firewall blocks and XP locks up for 5mins.



-----Original Message-----
From: Jeff D. Hamann [mailto:jeff_hamann at hamanndonald.com]
Sent: 18 March 2003 19:21
To: samba at lists.samba.org
Subject: [Samba] even worse after another upgrade to 2.2.8!

I haven't had any luck printing to printer attached to my FreeBSD machine
using samba (local printing works fine) after upgrading to 2.2.7a and using
XP. I could see my shared home directory from both XP and 2K and can still
see my home dir from the w2k machine. Now, when I try to map to my home dir
from XP, the printer status window appears (this time without the "access
denied" message), I cannot map to my home directory. On the windows 2k
machine, I don't get the "access denied" but can't print either.

So, in frustration, I went into the XP registry and tried to delete every
reference to the samba resources (printers, shared drives already mapped,
etc) and I still get the same responses.

Here's a list of the actions:

1) When I attempt to map my user shared drive (in xp), the printer status
window for the only printer on the unix machine appears without error
2) When I attempt to map to the only printer on the unix machine (in xp),
the printer status window apprears briefly, then goes away.
3) If I select the user dir to "map to a network drive" I get the printer
pull-down menu "open, connect, etc, etc". again xp
4) Same with the real printer. When I try to connect, a windows flashes and
I get nothing. again xp machine.
5) On the win2k machine, I can see the share drive, map, etc. everything is
okay for the shared drive.
6) on the 2k machine, the printer window comes up without error messages,
but I still cannot print.

Here's the log file from the activity so far...

ack! I cannot get to my shared drive so I'll have to get the files by floppy
or something...

There must be a version that works (I've updated from 2.0.10 and it worked
fine with all my win2k machines).

Please help.

More information about the samba mailing list