[Samba] can not join domain

John H Terpstra jht at samba.org
Tue Mar 18 00:18:46 GMT 2003

On Mon, 17 Mar 2003, Judy Lin wrote:

> Also, I am able to log into the local machine (not domain) and access the
> samba share from there.  But I am just unable to join the domain for some
> reason.  Can anyone see why the steps I took didn't work?

If you connect to the Samba server via network neighborhood then before
you can join the domain you need to (from as command shell) run:

	net use * /delete

This will drop the current connection to the samba server and allow the
domain join process to setup it's own connection.

Also, have you applied the registry change to turn off sign and seal?
You will find the patch you need in the ~samba-2.2.8/docs/Registry

- John T.

> Judy
> On Mon, 17 Mar 2003, Judy Lin wrote:
> > I have samba 2.2.8 is running as a PDC on RedHat Linux 7.3.
> > I can't seem to get my Windows-XP machine to join the domain.  Other
> > machines are already in the domain and work fine.  But when I tried to add
> > another machine to the domain, I'm running into problems.  I added a
> > machine account to the unix password file.  I also added a machine account
> > to smbpasswd.  Then, on the XP machine, I tried to join the domain and it
> > asks me to provide a username with privileges (which is root) in this
> > case, which also exists in /etc/passwd and smbpasswd.  Somehow it can't
> > find the PDC but it sill lets me join the domain.  When I go to log in, it
> > says it can't find a PDC.  Is there anything I'm missing here?
> >
> > Judy
> >
> > --
> > To unsubscribe from this list go to the following URL and read the
> > instructions:  http://lists.samba.org/mailman/listinfo/samba
> >

John H Terpstra
Email: jht at samba.org

More information about the samba mailing list