[Samba] Win2k, Domain logon, permissions

Brock Nanson bnanson at true.bc.ca
Mon Mar 10 01:06:50 GMT 2003

Hi Kurt,

Thanks very much for the reply.  My comments are inline...

> -----Original Message-----
> From: Kurt Weiss [mailto:input.maillists at kwnet.at] 
> Sent: March 8, 2003 12:06 AM
> To: Brock Nanson
> Cc: samba at lists.samba.org
> Subject: Re: [Samba] Win2k, Domain logon, permissions
> Brock Nanson schrieb:
> > I first asked this question at the end of October, got a response 
> > which didn't solve the problem, and have finally got back 
> to the issue 
> > now.
> > 
> there where the same problem with excel/winword files 
> anywhere, i think 
> there should be much to read in the archives :-(
> > -I can view the directory and see the temporary file in it, called 
> > $cvp$tp.dwg. -Allowing the command to complete, the file is 
> removed as 
> > it should be.
> > 
> to find out, where the problem lies, please try
> "oplocks = no"
> afterwards u can try
> "dos filetime resolution = yes"
> "dos filetimes = yes"

Tried all three of these settings.  Was forced to set 'level2 oplocks'
to 'no' as well, as testparm flagged this as being required.  However,
no joy from any or all of these settings.... :-(

> LanDevelopment Desktop seems to use more threads, and one 
> does not know, 
> what the other does. ('cause, there's running very much arx 
> applications.) did u look to the autodesk hompage too? (maybe 
> thats an issue, which 
> appears on w2k servers too...)

The first time I tried for a response on this problem from the list, I
got a single reply that suggested the problem *can* occur on w2k servers

> > As can be seen with the share definition above, I did try changing 
> > from my original owner/group setting of 'nobody, nobody' to 
> the real 
> > owner and the 'autocad' group.  My logic was that perhaps AutoCAD 
> > wanted to
> i don't think, that it's a permission problem, we're using AutoCAD, 
> Architectual Desktop and Mechanical Desktop on Samba and on 
> w2k servers 
> without ( ;-) ) problems...

Well, this is the only problem I have found...that's why I think it's an
AutoDesk problem.  However, since there are so many end users running
w2k, there must be a solution.  It doesn't show up in the knowledge base
at AutoCAD however.
> > The only thing I stumbled upon that might help someone suggest a 
> > solution was that killing and restarting the samba daemons 
> after the 
> > win2k box had opened the main drawing file will allow the 
> command to 
> > complete!  The main drawing throws an error when you next 
> try to save
> please report if/which switches had sucess.

Any other suggestions?  I wonder if the routine has been configured
incorrectly to be much more specific about the ownership of the file
that it wants to read.  But why it will work if the file exists on the
server already I can't get my head around!!


More information about the samba mailing list