[Samba] Re: Win95 & Win98 - NOT WORKING - NT,2000, XP are ok (reposted)

peter.a.bryant at mainroads.qld.gov.au peter.a.bryant at mainroads.qld.gov.au
Sun Mar 9 23:14:53 GMT 2003

File Sharing is working fine.
The problem seems to be getting the spooled file from the
Samba spool directory to the printers, and only on Win95 and 98.

The print command works ok when I run it from Unix...

see the bottom of my post for relevant conf file bits.



Kurt Weiss <input.maillists at kwnet.at> on 07/03/2003 06:54:35 PM

did u test if it's a printing problem, or if there's the same
problemwith file shares too???
can u post smb.conf

Peter A Bryant
07/03/2003 08:31 AM

To:   samba at lists.samba.org
Subject:  Win95 & Win98 - NOT WORKING - NT,2000, XP are ok (reposted)

>>Sorry to have to repost this (didn't get any response on the first post),
>>we really need some of the fixes of the new Samba but cannot go ahead without
the support for the older machines.
>>Need to prove that Samba is the great product that I believe it is.
>>Hi folks - I am having printing problems with our older machines.
>>Printing is working fine for our Windows NT, 2000 and XP clients.
>>However, with windows 95 & 98, the print job gets put into the Samba
>>spool directory (path = /var/spool/lp/tmp/samba)  but doesn't make it to the
>>The print files stay there in the directory - don't get removed.
>>Samba version is 2.2.7a,  on Solaris 8
>>Printers are HP printers - e.g. HP 8100dn
>>All clients including 95/98 were happily printing on a very much older version
of Samba (2.0.6)
>>printing directly from Unix to the printer is working ok
>>Has anyone experienced this problem or have any advice on how to
>>get my older boxes printing with the latest Samba?
>>any thoughts welcome - no really - anything - please....
>>(p.s. Just for a wild stab in the dark I tried setting the "disable spoolss =
>>but this stopped all printing from making it to the computer - even from the
clients that were originally working.)
>>relevant bits of conf. file included below...
>>note that I don't have print command explicitly stated, but testparm
>>indicates that it is configured properly...
>> printing = sysv
>> lprm command = /usr/bin/cancel %p-%j
>> lppause command = lp -i %p-%j -H hold
>> lpresume command = lp -i %p-%j -H resume
>> load printers = no
>> printer = hp8100dn_1
>> comment = HP LaserJet hp8100 DN
>> path = /var/spool/lp/tmp/samba
>> guest account = nobody
>> guest ok = yes
>> browseable = yes
>> printable = yes
>> writable = yes

Opinions contained in this e-mail do not necessarily reflect
the opinions of the Queensland Department of Main Roads,
Queensland Transport or National Transport Secretariat, or
endorsed organisations utilising the same infrastructure.
If you have received this electronic mail message in error,
please immediately notify the sender and delete the message
from your computer.

More information about the samba mailing list