[Samba] printer configuration issue

haiku at lowplaces.net haiku at lowplaces.net
Sun Mar 9 03:20:24 GMT 2003


Thank you for responding!

> haiku at lowplaces.net schrieb:
> > My thanks to everyone for their suggestions.  I can summarize recent
> > developments as follows:
> >
> > 1) after adding "use client driver = yes" (as Daniel suggests below), the
> > "access denied" message went away, but printing from a remote Windows
> > client still failed.
> >
> > 2) printing to the same device ("\\penguin\lp") from the same remote
> > client succeeds from a DOS window if I first set up a local print device
> > via the command "net use lpt1: \\penguin\lp" and then printed a simple
> > test file from the command line.
> when i updated, i had a similar problem:
> printing from a netadmin - was ok...
> printing from a netuser - access denied...
> this was my print section:
>   [printers]
>     comment = All Printers
>     browseable = no
>     printable = yes
>     public = yes
>     read only = no
>     create mode = 0666
>     path = /netzwerk/print
> unfortunally (in samba 2.0.X al was running) i did not have 'x' - rights
> on /netzwerk/print - i've changed rights of this temp directory - and
> all was running fine.

By "x" rights I assume you mean execute rights.  I believe I have this
covered because my path was created with 1777 permissions.  Unfortunately
this made no difference.

> one user was still not able to print over samba...
> so if i tried to install the printer over 'new printer' - 'network' - ...
> he got always 'access denied'...
> now i've installed this printer over 'new printer' - 'local printer' -
> 'new port' - 'local port' - '\\<server>\<printerport>' - ...
> and *jippppeyyy* the printer did run.

I've tried to fake out my Win2K system the same way - creating a new local
port that points to \\<server>\<printerport>, but this didn't work either.

> i don't know what happend at this time, because all other w2k machines,
> which was linked after this, where running well without workaround. -
> seems this machine did store something in registry, which causes teh
> error...
> it's only a experience, but i hope, it's something in for u...

It was worth a shot.  I haven't given up yet!


Paul David Mena
Haiku in Low Places, Ltd.
Email: haiku at lowplaces.net
Webpage: http://www.lowplaces.net

More information about the samba mailing list