[Samba] printer configuration issue

Kurt Weiss input.maillists at kwnet.at
Thu Mar 6 06:48:11 GMT 2003

haiku at lowplaces.net schrieb:
> My thanks to everyone for their suggestions.  I can summarize recent
> developments as follows:
> 1) after adding "use client driver = yes" (as Daniel suggests below), the
> "access denied" message went away, but printing from a remote Windows
> client still failed.
> 2) printing to the same device ("\\penguin\lp") from the same remote
> client succeeds from a DOS window if I first set up a local print device
> via the command "net use lpt1: \\penguin\lp" and then printed a simple
> test file from the command line.

when i updated, i had a similar problem:
printing from a netadmin - was ok...
printing from a netuser - access denied...
this was my print section:
    comment = All Printers
    browseable = no
    printable = yes
    public = yes
    read only = no
    create mode = 0666
    path = /netzwerk/print
unfortunally (in samba 2.0.X al was running) i did not have 'x' - rights 
on /netzwerk/print - i've changed rights of this temp directory - and 
all was running fine.

one user was still not able to print over samba...

so if i tried to install the printer over 'new printer' - 'network' - ...
he got always 'access denied'...
now i've installed this printer over 'new printer' - 'local printer' - 
'new port' - 'local port' - '\\<server>\<printerport>' - ...
and *jippppeyyy* the printer did run.

i don't know what happend at this time, because all other w2k machines, 
which was linked after this, where running well without workaround. - 
seems this machine did store something in registry, which causes teh 

it's only a experience, but i hope, it's something in for u...


More information about the samba mailing list