[Samba] Adding printer stops with "Operation could not be com pleted"

Peter Carpenter peterc at osm.co.uk
Mon Mar 3 15:33:09 GMT 2003


For what it's worth I finally got the "Add Printer" wizard working with
Samba 2.2.6 at the Unix end and Windows NT as the client. But it was a hell
of a struggle! Don't know if it works with Samba 2.2.5 and/or Windows XP.
BTW I don't see an "add printer command" in your smb.conf extract - don't
you need that?


-----Original Message-----
From: Tor Bechmann Sørensen [mailto:tor at studentergaarden.dk]
Sent: Monday, 03 March, 2003 5:44 PM
To: samba at lists.samba.org
Subject: Re: [Samba] Adding printer stops with "Operation could not be

I am still hoping that someone might have an answer to my problem, as 
stated below. Since my last post I have tried the all windows OS 
versions bundle driver from HP. It apparently installed, the 
printer property panel, sharing, additional drivers showed all 
drivers as installed (X86), but on the server actually only 
windows2k/Xp was present. In addition any computer which installed 
the printer now crashed explorer.exe every time a printing 
operation was tried. So I erased the drivers, and uninstalled the 
printer in winXP, and tried with "default devmode = yes". Now printing 
doesnt cause crashing, but the printer property in windowsXP still shows 
all drivers installed, and still the win95/98 drivers are actually not 
there. I have included my previous post below, FYI.

Regards Tor Bechmann Sorensen

> When trying to add the drivers downloaded & extracted from HP 
> (lj456ps.inf from lj632en.exe) I get the following message:
> "Unable to install HP LaserJet 5P/5MP Postscript, Windows NT 4.0 or 200, 
> Intel driver. Operation could not be completed."
> I also tried installing win95/98 drivers. In this case some files are 
> copied but then I get the equivalent of the above message for 95/98.
> I am adding them from a windows XP machine. I am loggin onto the samba 
> shares with my account which is in the staff group on the server.
> When I try to change some settings in the properties, like "hold 
> mismatched documents" I get an access denied error message.
> Ive set up my smb.conf like this (relevant lines only):
> [global]
>   printer admin = @staff
> [print$]
>     path = /var/prndrv
>     guest ok = no
>     browseable = yes
>     read only = yes
>     write list = @staff
> /var/prndrv looks like this  
> drwxrwxr-x    2 root     staff        4096 Mar  2 03:07 W32ALPHA
> drwxrwxr-x    2 root     staff        4096 Mar  2 03:08 W32MIPS
> drwxrwxr-x    2 root     staff        4096 Mar  2 03:08 W32PPC
> drwxrwxr-x    2 root     staff        4096 Mar  2 05:18 W32X86
> drwxrwxr-x    2 root     staff        4096 Mar  1 20:43 WIN40
> and /var/prndrv itself has same ownership/permissions.
> I am using samba 2.2.5. 
> The host specific log noodless.log (noodless is the win client i use to 
> add the drivers from), shows no error messages. It does give a lot of 
> messages, too much to quote here, but none of them are informative to me. 
> Help would be appreciated
> Regards 
> Tor Bechmann Sorensen


To unsubscribe from this list go to the following URL and read the
instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list