[Samba] smbclient - session setup failed: NT_STATUS_UNSUCCESSFUL

Dan Newcombe Newcombe at mordor.clayton.edu
Wed Jun 11 21:03:16 GMT 2003

I have been using Samba for years and am at my wits end with this problem.

I have 3.0.0beta1-1 installed (actually, it's the latest Debian unstable
package).   I just upgraded it - it was working fine yesterday.

I have rejoined my machine to the domain (did this by creating the account
using NT4's Server Manager to add it and then
 net rpc join CCSU  -U dnewcomb%password -W CCSU
(The domain is a w2k domain).  The above worked fine (so it says :)

I then tried to connect to my machine

 smbclient //mordor/dnewcomb -U dnewcomb%password -W CCSU
and I get
 session setup failed: NT_STATUS_UNSUCCESSFUL

However, if I "mistype" my password, I get
session setup failed: NT_STATUS_LOGON_FAILURE

so at least it is hitting the DC to validate the password.
My smb.conf has (and was working yesterday)
   workgroup = CCSU
   server string = Mordor
   invalid users = root
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   security = domain
   encrypt passwords = true
   socket options = TCP_NODELAY
   wins server =
   dns proxy = no
   obey pam restrictions = yes

   comment = Home Directories
   browseable = no
   writable = yes
   create mask = 0700
   directory mask = 0700

I'm guessing it is something with verifying my machine as part of the
domain or something, but I am stuck as to how to go about figuring out
what the problem is.  A little more verbosity in the reason for the
failure would have helped :)   unfortunatly the debug output means nothing
to me.  About the only thing in /var/log/samba is log.smbd which has
[2003/06/11 17:01:49, 1] sam/idmap_tdb.c:db_idmap_init(331)
  idmap gid range missing or invalid
  idmap will be unable to map foreign SIDs
but that shouldn't be an issue should it as I'm not using winbind.

Thanks for any help...I'm losing what hair I have left - meaning my
eyebrows :)

More information about the samba mailing list