[Samba] SMB won't authenticate

Patrick Nelson pnelson at neatech.com
Mon Jun 2 08:18:11 GMT 2003

On Sun, 2003-06-01 at 16:48, Tom McKellips wrote:
> Is the member server getting the authenticated username and password? The 
> member server has to be able to know the user is allowed to use the share.
> I setup mine a little different I used NFS from the member back to the 
> primary and then just assigned the drive as if it was on the primary.
> Just a thought.
> On 01 Jun 2003 16:01:05 -0700, Patrick Nelson wrote
> > Have a Samba PDC which authenticates the users login to the domain.  
> > But when I try to mount a share from a member server in the domain,
> >  I get errors like this:
> > 
> >   Closing connections
> > [2003/06/01 15:50:46, 2] smbd/reply.c:reply_sesssetup_and_X(985)
> >   Defaulting to Lanman password for pnelson
> > [2003/06/01 15:50:46, 2] lib/access.c:check_access(327)
> >   Allowed connection from  (
> > [2003/06/01 15:50:47, 2] smbd/service.c:make_connection(331)
> >   Invalid username/password for neatech [pnelson]
> > [2003/06/01 15:50:47, 2] lib/access.c:check_access(327)
> >   Allowed connection from  (
> > [2003/06/01 15:50:49, 2] smbd/service.c:make_connection(331)
> >   Invalid username/password for neatech [pnelson]
> > [2003/06/01 15:50:49, 2] smbd/server.c:exit_server(461)
> >   Closing connections
> > 
> > I have tried to troubleshoot this for a couple days... I've run out 
> > of ideas.  I must be missing something simple (hopefully).  I think that
> > this worked at one time, but now I'm not sure.  The server that 
> > issued the above errors is a member server of the domain.  I'm login 
> > in from a W98se system.  The windows login works fine, the domain 
> > login works fine, the boot-up script window shows it self, but I 
> > cant login to mount the share from the member server.  Any help 
> > would be much appreciated.
> > 

Yes it does get the username and password.  I've found some interesting
things though.  But first the nfs is a great idea, if all else fails
that may be the way I try next.

So the username pnelson fails.  The system is ldap authenticated. 
pnelson is a ldap user.  On the PDC system the Domain login works great,
there is an entry in the smbpasswd file for the user pnelson.  The login
from win98 works.  However, the mounting of drives (from the login
script) to the member server fails with pnelson.  There is an entry in
smbpasswd on the member server for pnelson (I've checked the passwd
multiple times).  I can use smbclient -I <IP of member svr> -U pnelson
-L <netbios name of member server>, and I'm presented with a passwd
prompt.  Enter the correct passwd and I get a listing of info on the
member srv (wrong passwd fails).  When I try and do a mount from a Linux
system like :

 mount -t smbfs -o username=pnelson //<netbios of member srv>/<share>

I see an error like the one above.  So I tried a new user pnelsonsr and
this user authenticates.  Everything looks fine except that this user is
local not ldap'ed.  I then put an entry into smbusers of:

  pnelson = pnelsonsr

and unmounted and remounted the mount.  This fails again.  I'm not sure
what is making this fail.     

More information about the samba mailing list