[Samba] Serious problem with samba-3.0.0beta* and printing

WIm Bakker wim at unetix.nl
Fri Jul 25 11:07:57 GMT 2003


I've tried both samba-3.0.0beta2 and beta3 but
both give me the same problem.
When on a windows dekstop and trying to add
a printer with samba as the printserver , the
printers exported by the samba server are not
seen by the windows desktop. e.g.:
relevant part of smb.conf:
        load printers = yes
        printing = cups
        printcap name = /etc/printcap
        print command = lpr -r -P%p %s
        path = /tmp
        read only = no
        printable = yes
        print command = lpr -r -Plp %s
  comment = all printers
  path = /var/spool/samba
  printable = yes
  browseable = no
  guest ok = yes
print daemon is cups , printcap is generated
tried to export both with the [printers] section and
specifically a section for a printer, but neither
way is it possible to find the printer using the 
"add printer" dialogue in windows, when in the dialogue 
searching the domain, the printers don't show up for selecting.
The odd thing is , they show up when browsing the network 
in the networkneighbourhood/networkplaces (w98/w2k)
Allso when in the "add printer" dialogue in stead off browsing the 
network to find the printer, I simply fill in the domainname of
the sambaserver and the name of the printer, it works, but 
I want the selectable printers to show up when 
browsing the network in the "add printer" dialogue actually.
This is important because one of the printers isn't actually
a printer but a fax server (hylafax ). Which brings me on the
second problem the printing to the faxserver, hylafax.
On the fileserver is hylafax running as fax server. Client
machines are all w98/w2k/wxp machines and they run a small
utility called respond.exe. On the fileserver is a printer
exported called fax according to the following section:
        comment = fax printer
        path = /tmp
        printable = Yes
        print command = ( /usr/bin/printfax.pl %I %s %U %m; rm %s ) &
        lpq command = faxlpq -P%p %s
        lprm command = faxlprm -P%p %j

Clients add this printer with the apple laserwriter as printerdriver.
When printing to the fax, the printfax.pl script connects back
to the client on a port where respond.exe is listening , which pops up
for the client to fill in the telephone number etc. But, this doesn't work
anymore with samba-3.0 , this works flawlessly under samba-2.2.8a, only
samba-2.2.8a doesn't work with w2k and user-customized login scripts,
which samba-3.0 does do flawlessly, so I'm stuck with either problems with
the printers or problems with the customized user logins.
Is it possible to mix the good things
of samba-2.2.8a with samba-3.0 ? please.
Wim Bakker
UnetIX Linux Solutions BV

More information about the samba mailing list