[Samba] could not login to samba server

Yuval Hager yuval at disksites.com
Sun Jul 13 14:15:02 GMT 2003


I am working with samba-3.0alpha20, and suddenly, one of the users could
not log in to the system. I worked with `wbinfo' and `id' (I am working
as security=daemon, using winbind in nsswitch.conf).

Here is what failed for `us2':
# id NTDOM\\us2
uid=10003 gid=10000(NTDOM\Domain Users) groups=10000(NTDOM\Domain Users)
/*<== pay attention that there is no username in parentheses after the
uid */
# wbinfo -s S-1-5-21-1789293116-3789330910-3885930141-1150  
Could not lookup sid S-1-5-21-1789293116-3789330910-3885930141-1150

And here is what worked for `us3':
# id NTDOM\\us3
uid=10000(NTDOM\us3) gid=10000(NTDOM\Domain Users)
groups=10000(NTDOM\Domain Users) # wbinfo -s
NTDOM\us3 1

All other wbinfo conversions (name to sid, sid to uid etc.) worked fine.
I was also able to list all domain users (wbinfo -u).

What I saw in the logs (log.winxp) was the following line:

[2003/07/13 12:21:19, 0]
  Couldn't find passdb structure for UID = 10003 ! Aborting.

After 80 minutes, the issue was resolved by itself (I have `winbind
cache time = 15').

Any ideas?



More information about the samba mailing list