[Samba] ls -l hangs

Heiko Ettelbrueck hbruckynews at gmx.net
Fri Jan 31 20:28:21 GMT 2003

Hi Chris,

Chris Unger wrote:
>      I just installed Samba 2.2.7a, --with-winbind --with-pam.  Everything
> appears to be working great, as far as logging in, authenicating to a Windows
> 2000 domain, creating/saving files. BUT, when I login to the UNIX box as root
> and goto the shared directory and type ls -al, all I get is:
> total 4
> drwxrwxrwx   2 root     other        512 Jan 30 09:44 .
> drwxr-xr-x  32 root     root        1024 Jan 29 14:14 ..
>      Running ls or ls -a work just fine. I am guessing it has something to do
> with the users/groups.

This problem sounds familiar to me. I tried winbind on a linux box to 
allow users to log in using their win domain user. Having searched a lot 
the www (without success) and mailinglists, I finally found a posting on 
the samba-technical mailing list where somebody complained about the 
same problem.

The problem seems to be a large number of users / groups in the domain 
together with winbind seeming to get a new list of all users / groups 
each time the corresponding pam module is called.

So the question is: How large is your win domain?

I think the guy I talked about had about 15,000 users, in "mine" there 
are over 60,000. The guy's "solution" was to change to samba 3.0 (it's 
alpha status today, as far as I know), as he had success with that 
version. Concerning "my" domain, I haven't tried samba 3.0 yet as I 
haven't been at the company for two months (it's a study/work 
combination). But I think I will try when I'm back at the end of february...

Perhaps you will try sooner and tell us about your experience?


More information about the samba mailing list