[Samba] Re: linux server completely hangs copying files with samba

Dragan Krnic dkrnic at lycos.com
Fri Jan 31 19:45:46 GMT 2003

>> final experiments;
>> after realizing that unloading the usb-ohci module (non even the
>> usbcore) system was fine, i compiled the kernel without modules
>> support and without usb. the machine crashed and actually i was 
>> really angry, becuase i thought i had found the problem; but 
>> finally i discovered that if usb is not loaded the machine 
>> crashes, but if i load it and unload it (going back to the same 
>> situation) it doesn't crash. obviously if i disale usb from bios 
>> everything in ok. maybe is something about irq, so if it is 
>> enabled in bios the ira (11 for me) is used. loading and
>> unloading the module will do something strange to the irq
>> handles. cat /proc/interrupts gives 0 on usb. at this point i'm 
>> curios to find out why this happens; since i've red of
>> many people having this problem maybe someone (not you, as you
>> told me) had a similar situation.
>> don't know if it's relevant, but only once the keyboard was 
>> blocked, i had to unplag and plug it back (ps/2 keyb) and it was 
>> ok, checking the interrupts they had jumped from 1500 to about 
>> 3000 in few seconds. going to work, nice day
>I forget how recent your hardware is, but have you tried booting with:
>lilo: linux noapic

That's one of the fírst things I tried. Didn't help, but nodma
(or something similar disabling IDE DMA) did.

Get 25MB, POP3, Spam Filtering with LYCOS MAIL PLUS for $19.95/year.

More information about the samba mailing list