[Samba] Second Posting! Please reply - Need HELP!!

issue qad issueqad at yahoo.com
Mon Jan 20 16:53:00 GMT 2003

I am first time SAMBA user. System information:
Unix = HP-UX 11.0
Network = Windows 2000

Things that I did:
1)	Logged into our test unix box as “root”. Created a
directory “samba” underneath “/home/root”.
2)	Went to samba website and downloaded
“samba-2.2.7a.tar.gz” onto my “C:\” (my desktop). I am
aware that the latest “How to” book in its
“Installation section asks me to use command “wget
from my unix prompt, but unfortunately “wget” does not
work on my unix box.
3)	FTP the “samba-2.2.7a.tar.gz” to test unix box in
binary mode.
4)	Used “gunzip samba-2.2.7a.tar.gz”
5)	Next step would be to verify Samba’s PGP signature.
But again, unfortunately, “gpg” command does not work
on my machine, so had to proceed further without
verification. Should I have used a different approach
for this verification?
6)	Used “cd /tmp”. Then did “tar xf
/home/root/samba/samba-2.2.7a.tar”. This did create
the directory “samba-2.2.7a” underneath “/tmp” and
with all the other folders and files underneath
7)	Then went back to
“/samba/ftp/Binary_Packages/hp/samba-2.2.7a” website
and downloaded the HP-UX depot
“samba_2.2.7a_HPUX_withwinbind.depot.gz” onto my “C:\”
and then FTP’ed that over to test unix box in
underneath “/tmp” directory in binary mode.
8)	Then used “swinstall –s
/tmp/samba_2.2.7a_HPUX_withwinbind.depot.gz Samba”.
9)	Then used “/sbin/init.d/samba start” to start smbd
and nmbd.
10)	Then edited my “/etc/nsswitch.conf” to add 
“passwd: files winbind
grouyp: files winbind”
11)	I think I am also supposed to do some setup in
“/etc/pam.d”, but this file never got created. It does
not exist.
12)	Used “/usr/local/samba/bin/smpasswd –j mydomain –r
mypdc –U administrator”. This joined the unix server
to “mydomain”. But also gave the error message about
“Unicode_map.850” and “Unicode_map.ISO8559” didn’t
exist underneath “codepages” directory. I know that I
do have “CP850.txt” and “CPIS8559.txt” files, but I
was not able to create those binary Unicode files
because I do not have the right “make_unicodemap”
excecutable. Can someone help me with this? I have
“make_unicodemap.c” executable but that seems be
taking input file in format “unicode_def.850”, which I
do not have. But note that I was able to Join to
13)	When I looked at “/usr/local/samba/log.smbd” and
“log.nmbd” files they had the same error message of
above two Unicode files not existing. But those two
processes “smbd and nmbd” start properly and I can see
them running on the box.
14)	Then copied libnss_winbind.so to “/lib” and
pam_winbind.so to /lib/security.
15)	I copied
“/tmp/samba-2.2.7a/examples/simple/smb.conf” to
/usr/local/samba/lib. I edited this file to add
following into [global]:
Winbind separator = +
Winbind cache time = 10
Template shell = /bin/bash
Template homedir = /home/%D/%U
Winbind uid = 10000-20000
Winbind gid = 10000-20000
Workgroup = mydomain
Security = domain
Password server = *
Encrypt passwords = yes
16)	 Then I start “winbind daemon” by using
“/usr/local/samba/bin/winbindd –s
17)	And bingo, I was able to achieve my objective of
able to access Unix files from my “windows explorer”
underneath “Network neighbourhood”.
18)	Now my problem begins. I tried to get fancy and
wanted to add some more directories that users can
access from Windows explorer. So I went ahead and
edited “/usr/local/samba/lib/smb.conf” for those
directories. Now I needed “winbindd” to see these
changes. But I did not how/from where to use “SIGHUP”
to reload my smb.conf. I did a “find / -name sighup
–print” and I was unable to get any instances. I tried
the same with SIGHUP (caps) and cannot find any
instances. So I thought of just taking down this TEST
unix box. I used “shutdown –ry now” [probably FIRST
MISTAKE during this samba set-up].
19)	After the unix box was back up I tried to use
start smbd and nmbd. “nmbd” was able to start up
without any problems. But smbd didn’t start. When I
looked at “log.smbd” I saw the error message of
“Unable to start messages database”. And when used
“/usr/local/samba/bin/smpasswd –j mydomain –r mypdc –U
administrator”, system still joined to mydomain. When
I start “winbindd”, it won’t start and gave me error
messages in “log.winbindd” that “Unable to start idmap
databases”. Also I noticed that my
“/usr/local/samba/var/locks” directory was GONE.
Because that was one of the error messages in
“log.winbindd” that could not find
“/usr/local/samba/var/locks”. That’s when I realized
that I could have corrupted the database files like
“/usr/local/samba/var/locks/winbindd_idmap.tdb” and
20)	That’s when I proceed to my biggest screw up of
reloading the entire software again. To do that, I
deleted following directories:
	I was not able to delete a file
“/usr/local/samba/lib/winbind/libnss_winbind.so”. If I
try to use “rm –f 
/usr/local/samba/lib/winbind/libnss_winbind.so”. I get
the message “rm: libnss_winbind.so not removed.  Text
file busy”. I was logged in as “root”. So I was unable
to delete “/usr/local/samba” directory. Also, I
deleted the file “/etc/rc.config.d/samba”. Then I
started to load things back by using above steps 1
through 8. After this when I looked at
“/usr/local/samba/” there was nothing created
underneath there by this new load. No other
directories created, only thing in there was
“lib/winbind” with the file “libnss_winbind.so” which
I was not able to delete. Also, file
“/etc/rc.config.d/samba” did not get created either.
Probably this file is used for running smbd and nmbd.

Many of you are probably saying “I screwed up big
time”, I know. So what can I do at this point? Any
chances of me to get back to where I was (working
condition)? This is all on my test unix box.

Appreciate all your sympathy.

Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.

More information about the samba mailing list