[Samba] PDC Trouble

hans at sbsfor.com hans at sbsfor.com
Fri Jan 17 19:11:06 GMT 2003

Running 2.2.7a as a Samba PDC.  My root account seems to have been killed
off.  I can't join computers to domains, I can't add users, I can't login
with a 2000 box as root.  If I try and login as root I get  "The system
cannot find message text for message number 0x%1 inthe message file for %2"
.  It's possible that I really pooched it.  I migrated our PDC to samba from
an NT4.0 box, using the various instructions regarding RIDS/SIDS.  I hacked
passwd.db to use lose the UID/GID to RID mapping, so i wouldn't loose the
locall profiles on my network.  That all worked, it's just now I have no
root acct to try and add machines.  If i try and add users with adduser and
smbpasswd, the users shows up fine in in /etc/passwd and
/usr/local/samba/private/smbpasswd.  I can't logon as those users however.
I've tried adding machines on the fly, and manually.  No good.  Any fixes,
or is the consensus that it's hooped and I should start again.


Hans Rasmussen
Drafting/GIS Coordinator
SBS Forestry Inc.

All emails incoming and outgoing from SBS Forestry Inc.
are scanned by Kaspersky Antivirus.

More information about the samba mailing list