[Samba] Add User Trouble on SMB LDAP PDC 2.2.7-1.1mdk

Jim jcllings at tsunamicomm.net
Sun Jan 5 04:42:01 GMT 2003

I am having a problem getting the system to automagically add a machine 
account to the LDAP database.

add user script = /usr/share/samba/scripts/smbldap-useradd.pl -w -d 
/dev/null -g machines -c 'Machine Account' -s /bin/false %u

Now the above works fine from the command line but will not execute from 
the server.  When it is added from the command line I can join the 
domain with no trouble.  This would seem to indicate that my admin user 
group is OK and I've currently go the ADLs cut down to nothing for 
testing.  I've tried it with security = user and security = server also.

I guess what I could really us is a test proceedure.  How can I find out 
  what is really going on?  I already tried using Ethereal to snif the 
packets after turning off ssl but found no clues there.  I also tried 
putting in a bash script that only leaves evidence of execution ( like 
touch'ing a file or echo'ing something.)  I go no such evidence of 


More information about the samba mailing list