[Samba] 3.0.0->3.0.1 = 2 problems - outlook & browsing fails

Rauno Tuul rauno.tuul at haigekassa.ee
Tue Dec 30 12:50:36 GMT 2003


I upgraded my 3.0.0 setup to 3.0.1. Basic functions worked well: logging to
domain, login script executes, home drive gets connected, PDC is browseable,
shares accessible. Network WINS server is a Win 2000 server, not samba PDC.

First problem appeared, when users tried to open their Outlook mailbox'es to
exchange 5.5 (on win 2000 server). Some users got into their mailbox, others
couldn't. Outlook asked for username and password (even if typed in correct
password, user couldn't open mailbox). 

Second problem is was that users couldn't access other windows
servers/workstation shares. Start -> run -> \\hostname or \\ip gave 2
different errors:
"An extended error has occured"
"The system cannot find message text for message number 0x in the message
file for \\hostname."
Eiher way, the shares list wasn't accessible. (Users couldn't print and so
on). Sometimes, after a few minutes, I could open that machines share list,
but when trying later, again failed.

At the moment I downgraded my PDC to 3.0.0 and things started to work again.
I'm able to open my mailbox, browse other win machines.
Samba logs (log level 3) or windows event viewer doesn't show any seriuos

For about 10 times today (after user login):
[2003/12/30 13:15:37, 0] lib/substitute.c:alloc_sub_basic(500)
  alloc_sub_basic: NULL source string!  This should not happen

for 800 times I got today:
[2003/12/30 13:21:40, 3] smbd/trans2.c:call_trans2qfilepathinfo(1934)
  call_trans2qfilepathinfo: SMB_VFS_STAT of SNMPAPI.dll failed (No such file
or directory)

What went wrong with my 3.0.1???  has anyone else ran into this situation?

I used exactly the same configuration parameters as in 3.0.0 (/configure
--with-ldap --bindir=/bin --sbindir=/sbin --sysconfdir=/etc/samba
--with-configdir=/etc/samba --with-logfilebase=/var/log/samba --with-quotas
--with-sys-quotas --with-acl-support).
I haven't tried any other rc's between 3.0.0 and 3.0.1...

My smb.conf has been the same for several weeks...

Looking for some help...


 Rauno Tuul

More information about the samba mailing list