[Samba] Configuring 3.0.1r2 Issues: Can't find libldap

Harmon, Leigh lharmo02 at harris.com
Tue Dec 23 17:06:05 GMT 2003

I'm running Solaris 9.  The first few times I tried to configure samba, I
received an "checking for ldap_initialize... no
configure: error: libldap is needed for LDAP support" error.  I saw an archived
post that was sent in Sept that said I need to install openldap from
www.openldap.org <www.openldap.org> .  Here is the posting:

	You need libldap from openldap. You can download openldap from from
www.openldap.org <www.openldap.org>  and compile it as follows: 
	./configure --without-bdb --disable-bdb --enable-null 
	make depend 
	make install 
	put /usr/local/lib in your LD_LIBRARY_PATH before compiling Samba 3. 

After installing openldap, however, I am still getting the same error.  I read
somewhere that there is a config.cache file that may be causing my problems, but
I can't find the file.  Any help would be greatly appreciated.


More information about the samba mailing list