[Samba] emergency- machines kicked off network after PDC 2.2.8->3.0.0 upgrade

Brett Dikeman bdikeman at bitpipe.com
Wed Dec 17 15:35:18 GMT 2003

After upgrading our PDC to 3.0.0 last night(and confirming logins worked 
properly)...this morning, we had two machines report errors says the 
machine account does not exist or has been changed.  Last night, users- 
even ones who had not been on that particular workstation before- were 
able to login on at least 6 out of 30-40 workstations.

All configuration files were moved over, including the "secrets" file- 
logins worked just fine.  Searches on google turn up nothing helpful, 
and attempts to use smbpasswd have failed.  I just attempted to add a 
new machine(well, a machine that was added to the old PDC, after we 
sync'd config+pw files) to the domain, and received:

# smbpasswd -m czar
Failed to find entry for user czar$

The entry does in fact exist in /etc/passwd and /etc/shadow.

I then tried pdbedit -a -m -u czar

When I went to the system and tried to re-add it to the domain, it 
claimed the domain did not exist or could not be contacted.

To eliminate iptables from the problem, even though 137-139 tcp+udp were 
open, I shut it down.  No change.

The "upgrading" doc mentions nothing that would help us in this 
extremely straightforward(machine trust accounts) issue...I've found it 
to be severely lacking.  This is extremely disappointing...


More information about the samba mailing list