[Samba] Domain account

Greg Dickie greg at justaguy.ca
Wed Dec 17 03:49:20 GMT 2003

Hi Dede,

  Just to confirm. You are logged onto the workstation as local administrator 
(or a local account with admin privileges) correct? Then you try to join the 
domain and when it asks you for the username & password you use root and the 
root password yes? Have you added the root user in your samba password 
database with smbpasswd?

 This usually works pretty easily and I don't understand why you would get 
that error.


On Tuesday 16 December 2003 23:35, Dede NURMANSYAH wrote:
> Dear All,
> Sorry if this question has been posted before but there's no enough answer
> to solved my problem and I'm going crazy because of it....:(
> I'm currently installed Samba-2.2.8a as logon server on My FreeBSD 5.0.
> For Win 9.X client there's no problem at all. But when I tried to joining
> W2K client into  samba domain it's shown an error message such as :
>    "the account used is a computer account. use your global user account or
> local user account to access this server "
> I've already used root account to joining W2K client into my Samba Server
> and already put @wheel in domain admin group on my smb.conf too.
> Before that I've already added machine account using vipw into my passwd
> file.
> I hope there's anybody who could show me the missing part that I've forgot.
> Sorry if my English makes you confused. :)
> Regards,
> Dede Nurmansyah
> Here's my global part of smb.conf
> [global]
>              workgroup = NIX
>              netbios name = FreeBSD
>              server string = Samba 2.2.8a on FreeBSD 5.0
>             encrypt passwords = yes
>             domain admin group = @wheel, @smbuser
>             domain logons = yes
>             os level = 65
>             preferred master = yes
>             domain master = yes
>             wins proxy = yes
>             wins support = yes

Greg Dickie
just a guy
greg at justaguy.ca

More information about the samba mailing list