[Samba] Samba PDC + WinXP = problems fetching remote profiles

Dendik dendik at pochta.ru
Wed Aug 20 14:40:15 GMT 2003

Hi, everybody!

I have 20 WinXP client machines and a sever running
Samba (first try was with 2.2.8, now it's 3.0.0rc1).
If it matters to someone (for statistics, fun or for 
understanding the problem), i use Slackware 9.0 Linux,
kernel 2.4.20 on server (and clients are XPpro/SP1,
buld 2600 as far as i remember). I almost had no
problems configuring samba for browsing and fortunately
i don't need to worry about printing. And it also
was not difficult to set up a Samba PDC. And even
the first time i logged in with a test user account,
everything went fine. But when i tried to log in
with that very account from another machine, i
got Win hanging up for about two minutes and
blaming approximately the following way:
  "Windows can't log you on with local profile,
  using temporary profile. Changes done to this
  profile will be lost after you log off"
(phrase `local profile` seemed strange to me, but
Win really does what it should do, except not
down/up loading the profiles). After the message
disappears or i hit OK, Win loggs in normally,
downloads logon.bat and seems to behave fine, but
the profile is really removed after log off.

Recently (a few hours ago, thanks to decreasing
log level from 3 to 2) i noticed the following
text in samba log corresponding to this behaviour:

  [2003/08/20 17:51:54, 2] smbd/open.c:open_file(248)
    botan opened file botan/NTUSER.DAT read=Yes
write=No (numopen=1)
  [2003/08/20 17:51:54, 2]
    botan closed file botan/NTUSER.DAT (numopen=0) 
  [2003/08/20 17:51:54, 2] smbd/open.c:open_file(248)
    botan opened file botan/NTUSER.DAT read=Yes
write=No (numopen=1)
  [2003/08/20 17:53:17, 2]
    Closing idle connection
  [2003/08/20 17:53:17, 2] smbd/server.c:exit_server(558)
    Closing connections

The following is (probably not complete) list of what i
tried to do:
  *. Patch the registry. Definitely. I would not be able
    to join Domain without it.
  *. Patch group policies (on two test machines)
  *. Turn off EAP in network properties (there was such
    advice in some message here). Caused win to blame
    immediately after i try to log in and with other
    message. I don't remember it right now, but i will
    try it again, if you ask.
  *. Switch samba to LDAP authentication (i remembered
    a message on the mailing list, reporing success with
    Samba+XP using LDAP), but i did not make it far enough
    for Samba to authenticate users with LDAP, and i would
    anyway gladly appreciate help with LDAP, yet it's not
    my real trouble right now and i will hopefully cope
    it using heaps of doc on the net.
  *. Play with Samba's socket settings.

Grateful beforehand for any help.

PS. Excuse my poor english. Me not anglisch talk :).

PPS. I mailed this problem to the list a few weeks ago, but
the only ansewr i received was a suggestion about registry
patch (which was by that moment long time done) and i had
for some administrative reason postpone the work until now.

More information about the samba mailing list