[Samba] FW: Can't Access Samba Shares After Recent Windows Update (msblast)

Cameron B. Prince cameron.prince at kottmann.com
Fri Aug 15 14:05:50 GMT 2003

Hi again,

I just went over to a co-workers Windows '98 PC and asked her to try my
Samba share and she accessed it fine. So this proves to me that MS's update
did indeed break my access to Samba. Being Friday, a lot of folks are gone
today, but I'll try and find an unpatched W2K machine to further confirm

Hopefully, there will be a work-around for this.


 -----Original Message-----
From: 	Cameron B. Prince [mailto:cameron.prince at kottmann.com]
Sent:	Friday, August 15, 2003 8:32 AM
To:	'samba at lists.samba.org'
Subject:	Can't Access Samba Shares After Recent Windows Update (msblast)


I have been running Samba for years with no problems... I recently became
the victim of the MSBLAST worm and I ran Windows Update to fix the hole in
RPC. That was Tuesday. Yesterday, Thursday, I needed to move some files over
to my Linux server and as I usually do, I went to My Network Places ->
Computers Near Me in W2K and could no longer see my Linux server.

I restarted Samba and tried again with no luck. I had an SSH connection open
to the machine so I new the network was functioning. I tried to map a drive
to the machine by ip address and it still failed. I've tried everything I
can think of to get it working, but still haven't had any luck.

My Samba configuration is from July 24 and hasn't been changed since I added
inherit permissions on a share. Is this a case of MS making another attack
on Samba or am I missing something?

I'm using samba-2.2.7a on RH9 with security mode share.

Thanks for any ideas or help,


More information about the samba mailing list