[Samba] Samba beta3 w/LDAP as a PDC

Robert Harrison robstar at anotherdimension.net
Fri Aug 15 08:04:54 GMT 2003


I was just wondering whether there was any success with this problem as I
have just experienced exactly the same myself.

I'm running Debian testing/unstable (kernel 2.4.20-9), a clean install
with Samba 3.0.0beta2-1 configured as a primary domain controller/logon
server with an LDAP backend (slapd 2.1.22-1). My WinXP Pro SP1 client
appeared to join the domain successfully, the machine trust account looks
to be created, but attempting to logon as one of the domain users causes
Windows to display a message box containing the message "Procedure number
out of range".

My WinXP machine has had the registry patches applied as I used to have
the Samba PDC working prior to 3.0 beta. I must also stress that I've
recreated the LDAP database from scratch using the new samba schema.
Having looked through the Samba logs and Event viewer, there are no error
messages that suggest what is going wrong.

Any help gratefully received,
Rob Harrison.

p.s. I've also tried turning schannel off and then on, on both server and
client as there were some samba log messages stating:

Invalid auth info 68 or level 5 on schannel
  process_request_pdu: failed to do schannel processing.

appeared to have no effect to the windows message box.

Original message follows:

From: Marlys Nelson <Marlys.A.Nelson at uwrf.edu>
Subject: [Samba] Samba beta3 w/LDAP as a PDC
Date: Mon, 28 Jul 2003 12:59:06 -0500
Message: 18

I'm trying to setup a samba PDC and I seem to be missing a few pieces in the
puzzle.  I've reached the point where I've tried joining an XP workstation to
the domain (yes, I've applied 3 changes to the registry that have been
mentioned numerous times on the list).  The domain join appears to work
fine -
I get back a nice box from the Windows machine welcoming me to the domain.  I
then reboot and try to logon, and this is what is failing with an error
"Procedure number out of range".  There never is any attempt to retrieve my
logon info from the LDAP server so I think something is still going wrong
the machine account.


More information about the samba mailing list