[Samba] cifs samba mailing list

Goik goik at hdm-stuttgart.de
Tue Apr 22 19:31:22 GMT 2003

For two days now I've tried for two days now to get cifs working on a 
redhat 9.0  2.4.20 based linux box. I followed the instructions given at 
http://de.samba.org/samba/Linux_CIFS_client.html, i.e. compiling 
cifs-0.6.8 and mount.cifs rev. I successfully loaded the cifs.o 
as a module and  following the given examples I tried:

[root at r151-101 cifs]# /sbin/mount.cifs //raid/demo /stud/demo -o 
mount error 22 = Invalid argumentRefer to the mount.cifs(8) manual page 
(e.g.man mount.cifs)

This yields the following /var/log/messages block:

Apr 22 21:19:44 r151-101 kernel: CIFS: Unknown mount option ip
Apr 22 21:19:44 r151-101 kernel:  CIFS VFS: Error connecting to IPv4 
socket. Aborting operation
Apr 22 21:19:44 r151-101 kernel:  CIFS VFS: cifs_mount failed w/return 
code = -111

What does Unknown mount option ip mean here?

I also tried various other mount options with same result. Finally I 
tried the two older versions of mount.cifs (1.2 and 1.1) with no success.

The samba server is samba-2.2.5-1 with "unix extensions=yes" configured. 
I can access this machine via smbclient //raid/demo -U demo.

So maybe the mount.cifs helper is not appropriate? I scanned the samba 
mailing list for the past six months without success. Any hints greatly 
appreciated! I did not yet receive the samba mailing list confirmation 
to my subsription request, so please send me a "cc" if possible.

Regards, Martin

Martin Goik  Tel. +49-(0)711-685-8365  http://www.HdM-Stuttgart.de/~goik

More information about the samba mailing list