[Samba] Problem joining Samba 2.2.7 Domain with Windows XP

John Broadhead admin at americanconsultants.com
Wed Apr 16 15:27:50 GMT 2003

I am attempting to join a Domain named WORKGROUP on my Linux box running
Samba 2.2.7 from my SP1 Windows XP machine. Every time I try to join it says
that the Domain doesn't exist or could not be contacted. Many months ago I
was able to join all of our Windows 2000 machines to the same domain, but it
may have been an older version of Samba back then. Also, I haven't dared try
un-joining a Windows 2000 machine just to see if I can re-join it.

I have looked up a lot of documentation and gone through and added the
signorseal registry patch and gone into Policy editor and disabled a few of
the options as specified by some documentation I read.

I have a smbpasswd entry for my machine added with: smbpasswd -a -m sangita
(SANGITA is the machine name in System properties)

I have an entry in /etc/passwd and /etc/shadow for a disabled account named

I have an entry in smbpasswd for root with the password "admin".

In smbusers: "root = ntadmin"

My workgroup is currently set to "OTHER" and I am joining the domain
"WORKGROUP". It asks for a use and password and I type ntadmin and admin
(I've also tried root and admin). Then after a few seconds it comes back and
says that the domain doesn't exist or could not be contacted. I've used
Ethereal on the Windows XP machine to see if it can find the PDC for
WORKGROUP and it seems to work fine. One of the entries is a request for the
name of WORKGROUP<1b> and it gets back the correct address of
because it starts connecting to it. If anyone would like to see the Ethereal
capture I can send it, but I doubt it's appropriate to post it on this list.
I've looked through it and my layman eyes don't see any glaring errors.

I don't know how to make detailed logs on the server side. The only error I
see in sangita.log is:
[2003/04/16 08:55:16, 0] lib/util_sock.c:read_data(436)
  read_data: read failure for 4. Error = Connection reset by peer

But for the 5-6 times I tried to join the domain this morning this error
only happened the one time.

Would someone please help me to figure out what's wrong?

John Broadhead

More information about the samba mailing list