[Samba] winbind issues

Board, Clint cboard at ufsonline.com
Tue Apr 15 18:47:32 GMT 2003

Hi all :) <- newb to list

I am setting up RedHat 9 running samba 2.2.7a, i currently get the following
error in my log.winbind:

error connecting to xxx.xxx.xxx.xxx:445 (Connection refused)

also, i get this when i run wbinfo -u or -g:


and this when i run wbinfo -N xxx.xxx.xxx.xxx (this works fine if i pass the
netbios name instead of the ip):

Could not lookup WINS by name xxx.xxx.xxx.xxx

I am assuming that these issues stem from the same problem, however i am
somewhat new to samba so.... I have looked around and have not had any luck
on a resolution but have found mentions of the same issues. Attached is my
smb.conf, any help would be appreciated.

	workgroup = DOM
	netbios name = LINUXFILESERVER
	server string = LINUX Samba Server
	security = DOMAIN
	encrypt passwords = Yes
	min passwd length = 7
	map to guest = Bad User
	obey pam restrictions = Yes
	password server = *
	passwd program = /usr/bin/passwd %u
	passwd chat = *New*password* %n\n *Retype*new*password* %n\n
	username map = /etc/samba/smbusers
	log level = 2
	log file = /var/log/samba/%m.log
	max log size = 0
	large readwrite = No
	name resolve order = wins lmhosts host bcast
	socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
	printcap name = cups
	domain admin group = Domain Admins
	domain guest group = Domain Guests
	preferred master = No
	local master = No
	domain master = No
	dns proxy = No
	wins server =
	winbind uid = 10000-20000
	winbind gid = 10000-20000
	printer admin = root
	hosts allow = 198.210.229. 12.30.74. 127.
	printing = cups
	hide unreadable = Yes

	comment = Home Directories
	valid users = %S
	read only = No
	create mask = 0664
	directory mask = 0775
	browseable = No

	comment = All Printers
	path = /var/spool/samba
	printable = Yes
	browseable = No

	comment = Printer Drivers
	path = /etc/samba/drivers
	write list = root

More information about the samba mailing list