[Samba] strange behaviour in file timestamp on smbfs

diego apollonio diego.apollonio at txt.it
Fri Apr 4 11:10:39 GMT 2003

Hi all,
  I've notice a strange behaviour in smbfs and I was not able to understand 
it, so I want to share it with some other
We have some Solaris 7 machines with samba server and some linux workstations 
with Suse7.3 and SuSE 8.1 OS.
When we mount on the linux workstation on share of the Solaris machine we see 
the file modification timestamp wrong by one hour.
I was thinking about a problem in timezone settings, but the very strange 
thing is that if I touch a file from the workstation the time stamp is 
correct (and if you type a ls -l on the solaris machine the date is correct 
But if you make the opposite (touch a file from solaris) on the linux machine 
is again one hour wrong.

Timezone of Linux workstations is set to  CEST while on solaris machines is 
set to MET DST.
I've tried also to change the timezone on linux clients to MET, but nothing 
changed. (in any case MET and CET are either GMT+1, isn't it?)

Finally, using smbclient timestamps are correct. It seems that the problem is 
related on the linux smbfs. Mounting a linux share with smbfs the problem 
dosn't occours.

Someone has any idea? I've tried to read many docs but without success.


More information about the samba mailing list