[Samba] RE: Can you assist me? I have seen yours and Jennifer Fountains corr espondence

Wieprecht, Karen M. Karen.Wieprecht at jhuapl.edu
Tue Oct 29 14:47:28 GMT 2002

1. What version of samba?   You should be trying 2.2.5 or 2.2 6 for one of
the more stable winbind releases.
2. Are you running NIS?  Try changing the winbind separator to _
3.. Did you put winbind in your nsswitch.conf file?  If so,  did you force
the  system to re-read that info (happens automatically on solaris,  must
run nsadmin restart on Irix,  don't know about other platforms).
4.. Is that a typo in your smb.conf file where the username map entry is,
or just a typo in the mail message?
5. If none of these simpler things does the job,   try removing the username
map and the valid users first and see how far you get.  You can check the
client connection logs (~samba/log.hostname) to see who samba thinks you are
when you try to access the share from the PC.  Add your username map back
into the picture and see if "who you connect as" changes.   How you are
being identified in the connection log should help you figure out if you
need to put domainname+username or just plain username in for the valid
users.   Solve this piece by piece to get  the exact combination that does
what you want rather than adding too much complexity.  
Let me know how it goes,
        Karen Wieprecht
 -----Original Message-----
From: Jennifer Crusade [mailto:JCrusade at gtess1.com] 
Sent: Monday, October 28, 2002 5:03 PM
To: 'Karen.Wieprecht at jhuapl.edu'
Subject: Can you assist me? I have seen yours and Jennifer Fountains corr


I have a quick question you may be able to assist me with. I am doing the
same thing you are I can do all of the commands winbind -u 

winbind -g

getent passwd

getent group 

But when I set up a share to test with one domain user account it just
presents me with a password dialog box and does not accept anything. It
should not prompt me but if it does it should authenticate me an it does
not. I have tried it with the username map = /etc/samba/smbusers and that
did not work either. I have tried the valid user = with domain name and
separator and without nothing is working.  i know i am missing something

Here is my information:

#======================= Global Settings


workgroup = GTESS1.COM

netbios name = GTDNS

server string = Linux 7.3 Samba Server

log file = /var/log/samba/log.%m

security = domain

password server = *

wins server =

;username map = /etc/samba/smbusers

encrypt passwords = yes

winbind separator = +

winbind uid = 10000-20000

winbind gid = 10000-20000

winbind enum users = yes

winbind enum groups = yes

template shell = /bin/bash

winbind use default domain = yes

socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192


comment = TESTIT

path = /usr/stuff

valid users = GTESS1.COM+jcrusade

read only = No

create mask = 0777

directory mask = 0777


Jennifer Crusade 
GTESS Corp. 
CCNA, MCSE W2k\NT 4.0, MCP +I 


-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list