[Samba] SAMBA with mounted ISO images

Jon Monroe jmonroe at imagebuilder.com
Mon Oct 14 17:22:01 GMT 2002

Hey all,

I discovered that if I terminate my login "token" (or whatever you call it 
where the server has successfully authenticated your name/passwd and 
records this) then the locked folder becomes free after about 60 seconds. I 
tried this by doing a net login /d \\server\IPC$

I also noticed that after logging in, closing any open folders but NOT 
releasing my login session, that there are *2* records in the 
locks/connections.tdb file for my workstation. One of them has the IPC$ in 
the key, while the other is presumably just for the folder. Perhaps I can 
just delete this weird second entry manually to force release the folder 
lock that I'm not using anyway without having to logout/login everytime? :)

I forgot last time:
x86 RH 8.0, samba 2.2.5 compiled from regular samba source.
win2k, sp3 w/s

Thanks again,

On Sat, 2002-10-12 at 07:47, Jon Monroe wrote:
> > Hey all,
> >
> > I'm using Samba to share *mounted* ISO images w/ windows workstations. In
> > other words, I create a share w/ default write access. Then, I create a
> > several folders. Some are for files, while others are read-only and used
> > for mount points for iso9660 ISO image files (so the user sees the 
> contents
> > of the iso files, not the file itself).
> >
> > I can mount and share the ISO file contents fine. But I can't umount the
> > image (to say, switch to a newer version of the same named ISO file). Even
> > though nobody is using the server (windows stations switched OFF), Samba
> > seems to maintain a lock on the shared ISO mount point (the folder) and
> > won't let the resource be released
> >
> > If I do a force umount (-f) it doesn't help
> > If I do a lazy umount (-l), it does work, but it doesn't release the loop
> > device.
> > If I do a losetup -d /dev/<loop_device> it can't release it.
> >
> > But, if I shutdown Samba, it unmounts/releases fine.
> >
> > So, is there something I can configure or compile into Samba that will
> > cause it to not-lock/cache mounted folders so that one can umount the ISO?
> > I tried disabling all the known cache settings in the smb.conf -- 
> didn't help.
> >
> > Thanks a bunch!
> >
> > Jon

More information about the samba mailing list