[Samba] Winbind = yes

Nollaig MacLochlainn maccelt at hotmail.com
Wed May 22 11:57:02 GMT 2002


I have got winbind working on Solaris 8!
I got Samba 2.4 woring perfectly but I think it would be no proble to get
2.2.3 working either...

In the next few days I'll email some general documentation to this list
with the instructions to follow....

I am not at work so cannot give the exact details now.
but here is a tip..

First compile..

./configure --prefix=/directory --with-winbind --with-pam ... etc
gmake, gmake install

copy some libraries..

cp ./nsswitch/pam_winbind.so /lib/security/pam_winbind.so
cp ./nsswithc/libnss_winbind.so /lib/

ln -s /lib/libnss_winbind.so /lib/nss_winbind.so

then mess around with the pam.conf...

login account sufficient  /lib/security/pam_winbind.so
login auth    sufficient  /lib/security/pam_winbind.so
etc ..

Be careful .. I messed up and could't telnet in to my solaris server after a
modification.  Always keep a spare telnet session open.


1) Unable to change local passwords in /etc/passwd file due to
security restriction in the solaris passwd binary.  It checks the
nsswitch.conf for
a subset of name-services (files, ldap, nis, nis+, etc) but not winbind.

FIX:  Temporarily edit nsswitch.conf to remove "winbind" text,
change the password
edit nsswitch.conf again to re-enable winbind

2) I was unable to login to my Veritas Volume Manager today (access denied)
 locally.  This was due to my pam.conf.

I commented a "Other account ..." clause in my pam.conf temporarily
and login worked ok..

3) Winbind: Use Domain Name = No (default)
When this smb.conf clause I cannot telnet to the server as I do not know
what telnet expects.
I tried  login: "ie-domain-nt\account",
  login: ie-domain-nt\account
  login: account
  login: "account"

but none would work.

If I change Use Domain Name = Yes then I can telnet in successfully.

Fix:  I just use the default as I don't need to telnet in.
I was just interested if it could be done.


[Samba] Winbind
Thamara Wanigatunga thamara at jkcs.slt.lk
Thu May 2 02:16:02 2002



IS there ANYBODY who has got winbind working on Solaris ?. Is this thing
not compliant to Solaris or is there anything to work around?

Please help


More information about the samba mailing list