[Samba] Linux server, Win2k client: Almost works, what am I missing?

Keith G. Murphy keithmur at mindspring.com
Fri May 17 10:52:01 GMT 2002

Kris Kelley wrote:
> Once I fired up Samba, I tried to access it from a Win2k box, on which
> I'm logged in as DEVGROUP/skunk (user "skunk" also exists on the linux
> box, and the passwords are the same in both environments).  This failed
> with the usual "account is not authorized to log in from this station"
> error (clear text passwords are enabled on the Win2K box), and I only
> saw this in Samba's logs (level 2):
>    [2002/05/15 19:17:57, 2] smbd/reply.c:reply_special(91)
>      netbios connect: name1=SKUNKWORX        name2=WIN2KBOX
>    [2002/05/15 19:17:57, 2] smbd/reply.c:reply_special(110)
>      netbios connect: local=skunkworx remote=nfstest
> However, when I used the "net use" CLI command to log in with user
> "nobody", supplying "nobody"'s password, it worked!  The share was
> successfully mounted, and I saw these entries in the Samba log:
>    [2002/05/15 19:18:29, 2] smbd/reply.c:reply_sesssetup_and_X(973)
>      Defaulting to Lanman password for nobody
>    [2002/05/15 19:18:29, 1] smbd/service.c:make_connection(651)
>      nfstest ( connect to service test as user nobody
>        (uid=99, gid=99) (pid 15247)
Kris, I had a *very* similar problem, which your postings helped me
solve just now.  I, too, couldn't map Samba shares from a Win2K box. 
Your posting gave me the idea of trying to map a drive specifying a user
that didn't exist on the Win2K box.  Sure enough, that worked.

I had another piece of information, though.  I knew that my problems had
started when I screwed around with Win2K Kerberos authentication from
the Linux box using this article as a guide:


This is an extremely useful article, by the way.

I tried undoing everything I had done on my Linux box (deinstalling
libpam-smb and libpam-krb5, for starters).  Nothing worked.

However, I realized that back when I made Kerberos authentication work,
I had had to create a user on Win2K with the same name as my Linux box'
DNS host name.  (As described in the article).

Once I deleted that user from Win2K, everything worked right again.  :-)

I'm not at all sure why this happens.  I may mess with it a bit to find
out more.

I suggest you look for a username on your Win2K box that is the same as
the Linux host name you are trying to access.  Delete that bad boy, or
something less drastic that works...

Hope that helps.

More information about the samba mailing list