[Samba] A re-built WinXP won't join domain

Phil Chambers P.A.Chambers at exeter.ac.uk
Fri May 3 08:17:04 GMT 2002

I had to re-build an XP system from scratch.  The system had been joining my SAMBA 
PDC OK.  Before re-building, I made the XP system leave the domain and changed it to 
just being in the workgroup.  I then did a "smbpasswd -x -m -XPPC" on the PDC.

During the re-build I did not join the PC to the domain, just put it in the 
workgroup.  One running I found that "View Workgroup Computers" failed with the 
message "<name of workgroup> is not accessible.  You might not have permission to 
use this resource".  I could examine other workgroups though.

I put the PC back into the domain with "smbpasswd -a -m -XPPC".  When I tried to 
join the PC into the domain I got the message "A domain controller for the domain 
<name of domain> could not be contacted.  When I tried "nmblookup -B XPPC '*' on the 
PDC machine I got "querying * on <correct IP address" ... "name_query failed to find 
name *".

I can only assume that SAMBA is remembering something about the PC which is now 
different.  Any suggestions please?

Phil Chambers (postmaster at exeter.ac.uk)
University of Exeter

More information about the samba mailing list