[Samba] Printer Problem: Canon LBP-1000 & Samba (2.2.[3a,4,5])

Andree Leidenfrost aleidenf at bigpond.net.au
Sun Jun 30 01:50:03 GMT 2002

Dear Samba people

I am experiencing a weird problem with the above printer: When I upload
the printer driver to Samba to make it available to clients that connect
to the printer, these clients start showing printing problems but only
in some applications. OpenOffice gives the following error message when
trying to print:
|OpenOffice.org 1.0             |_|-|X|
|  ____                               |
| /    \   No default printer found.  |
| | \/ |   Please choose a printer    |
| | /\ |   and try again.             |
| \____/                              |
|                                     |
|                 <Ok>                |  

The same happens in e.g. AcrobatReader. MS Office, however, prints fine.

When the printer driver is not uploaded to the Samba server but locally
installed on the client machine, printing works without a problem.

I tried with a number of other printer drivers and they worked all fine,
so looks like it might be some specific problem with the driver in
conjunction with Samba.

I reported this problem a while ago in the Debian bug tracking system
(cf. http://bugs.debian.org/147231). Eloy Paris, the package maintainer
of the Debian Samba packages, was very helpful but eventually ran out of
ideas. ;-) He suggested I post my problem to the Samba mailing list, so
here you go...

NB, I also filed a bug against OpenOffice:

Best regards & thanks for your time

PS: I am not currently subscribed to the list, so CC'ing me would be
really helpful.

Andree Leidenfrost
Sydney - Australia

More information about the samba mailing list