[Samba] re: Data not written

Dennis Bottaro DJB at pringle.com
Wed Jun 19 06:41:52 GMT 2002

Thanks for the replies I have gotten - but I realize that I did not give
enough info the first time:
Here is the script that I am using:



umount /mnt/backup
mount -t smbfs //NTb/f$ /mnt/backup -o

smbclient \\\\Nta\f$ mypassword -I -U myuser -TcX
/mnt/backup/zeus.tar Inetpub\


The above script does the mount of the /mnt/backup just fine, and runs
through the motions of the smbclient line, processing each file, but it
never writes the tar files to /mnt/backup.

But if I run each command interactively, it does the job.

> I need to backup one WinNT machine through my linux box to another WinNT
> machine.
> Here is my setup
> NTa- WinNT 4 sp6a
> NTb- WinNT 4 sp4
> Tux - Linux 2.2 (RedHat 6.0 w/ updated kernel) running Samba 2.2
> When I issue an smbclient \\\\NTa\\Share -Tc /mnt/backup with /mnt/backup
> being a successfully mounted share on NTb it creates the file with out
> problem. However, when I run the same command from within a shell script
> does not write anything at all.
> Any help would be greatly appreciated! Thanks!

Dennis Bottaro
Pringle Development, Inc.

More information about the samba mailing list