[Samba] oplock break

Tim Bates batestim at iprimus.com.au
Mon Jun 10 04:38:02 GMT 2002

After some more research, I have more information on the oplock problem: 
The problem occurs when trying to copy files. I was originally using DOS 
xcopy. It copies cheerily along until reaching some seemingly random file, 
and then dies with "The specified network resource or device is no longer 
available". Then when I go back to delete the (half-copied) file through 
Explorer, it tells me 'access denied'. I then have to log into the server 
and delete it using good old 'rm'. If I now try to copy the same file using 
xcopy once more, the same error occurs on the same file. However, if I use 
Explorer to copy it, it copies that file quite happily and then gives the 
same error on a different, later file. I click OK, and the copy dialog sits 
there until I click Cancel on it, whereupon Explorer hangs the window for a 
good 15 seconds before doing anything, including redrawing itself. Once 
again, if I try to delete the file, I get a 15 second pause and then an 
'access denied'.

The oplock break messages in the log are persistant, even when I'm doing no 
more than looking at filenames, not even opening files. This makes me doubt 
the two being related, but since I have very little idea of how Samba 
operates, and no idea about what an oplock is, I'm hoping someone can help 
me out.
                                 Tim Bates

More information about the samba mailing list