[Samba] Compilation problem with samba2.2.4

Gerald Carter jerry at samba.org
Thu Jun 6 20:56:02 GMT 2002

On Mon, 20 May 2002, Jukka Holopainen wrote:

> Hello from Finland.
> I have couple problem to compile Samba 2.2.4
> I need LDAP options, and when I run
> ./configure --with-ldapsam everything going ok,
> but when I run
> make
> It gives couple error messages, thats are below:
> Compiling passdb/pdb_ldap.c
> "passdb/pdb_ldap.c", line 76: undefined symbol: LDAP_OPT_X_TLS_HARD
> "passdb/pdb_ldap.c", line 96: undefined symbol: LDAP_OPT_SUCCESS
> "passdb/pdb_ldap.c", line 128: undefined symbol: LDAP_OPT_X_TLS
> cc: acomp failed for passdb/pdb_ldap.c
> *** Error code 2
> make: Fatal error: Command failed for target `passdb/pdb_ldap.o'
> I run Sun Netra X1, with Solaris 8 and I using iPlanet LDAP-server,
> I allready download iPlanet SDK
> ldapcsdk5.08-SunOS5.8_64_OPT.OBJ.tar.

I;ve not tested the LDAP code with the Netscape libraries.
Use at your own risk.  However we do compile with the
OpenLDAP client libraries and with Sun's LDAP lib.
However, the latter apprently lacks SSL support.

cheers, jerry
 Hewlett-Packard                                     http://www.hp.com
 SAMBA Team                                       http://www.samba.org
 --                                            http://www.plainjoe.org
 "Sam's Teach Yourself Samba in 24 Hours" 2ed.      ISBN 0-672-32269-2
 --"I never saved anything for the swim back." Ethan Hawk in Gattaca--

More information about the samba mailing list