[Samba] Problem with pam_winbind

John McCawley jmccawley at worleyco.com
Tue Jun 4 08:50:03 GMT 2002

OK, I managed to solve my problem.

One of the 1000 documents I read had an smb.conf line that said:
domain logons = yes

After trying out their suggestion I forgot to remove it, and so my 
smb.conf was a little wacky.
I tracked this down after checking my logs in /var/log/samba and seeing 
that Win95 machines were logging into my linux server.  Then I noticed a 
line in smb.conf:

Mismatched SIDs as a pdc/bdc.

So I stopped samba, commented out the domain logon line, removed 
/etc/samba/secrets.tdb, reran smbpasswd, and started back up.
Voila!  Everything works.


John McCawley wrote:

> I tried mirroring your setup and I'm still getting the exact same 
> problem.  After seeing a similar post to mine, I checked 'wbinfo -t' 
> and got
> Secret is bad
> 0xc000018b
> Once again, I've tried every combination of removing/adding myself 
> from the domain I could think of and it still says the same thing.  
> I've restarted winbindd a hundred times.  I assume if I get the 
> 'Secret is bad' message then using pam_winbind won't work.  Is this 
> correct?
> John
> Oliver Thinnes wrote:
>> I have the same situation as you have (redhat 7.2, samba 2.2.4 
>> compiled with winbind, acl support and as a member of a NT 4 domain).
>> I configured /etc/nsswitch.conf like this:
> <snip>

More information about the samba mailing list