[Samba] Problem with pam_winbind

Ingmar Koecher ingmar.koecher at netikus.net
Tue Jun 4 08:21:06 GMT 2002

I have a similar problem as stated in a previous message "Winbind + machine 
account + non-anonymous access (RestrictAnonymous)"

Even though the samba box is correctly in the NT4 domain (or so it seems),
I get

Secret is bad

after running wbinfo -t

In my last email I forgot to mention that I am running Samba version 2.2.4 - 
downloaded 2 weeks ago (appr.).

I am also VERY curious to know if it is possible to use winbindd when the 
domain controller does not allow anonymous connections?

Thanks a lot,

On Tuesday 04 June 2002 12:13 pm, John McCawley wrote:
> I tried mirroring your setup and I'm still getting the exact same
> problem.  After seeing a similar post to mine, I checked 'wbinfo -t' and
> got
> Secret is bad
> 0xc000018b
> Once again, I've tried every combination of removing/adding myself from
> the domain I could think of and it still says the same thing.  I've
> restarted winbindd a hundred times.  I assume if I get the 'Secret is
> bad' message then using pam_winbind won't work.  Is this correct?
> John
> Oliver Thinnes wrote:
> >I have the same situation as you have (redhat 7.2, samba 2.2.4 compiled
> >with winbind, acl support and as a member of a NT 4 domain).
> >
> >
> >I configured /etc/nsswitch.conf like this:
> <snip>

More information about the samba mailing list