[Samba] FW: RE: Big problem with 2.2.X.

Mead, Tom tmead at bci.it
Thu Feb 21 03:55:02 GMT 2002

Sorry, My mistake it didn't fix the problem. (I was running the application
from the c:\ drive rather than the share). I am getting exactly the same
errors in the log: 

unix_clean_name [common/config/.root.passwords]
[2002/02/21 11:15:44, 4] smbd/open.c:open_file_shared(779)
  calling open_file with flags=0x0 flags2=0x0 mode=0644
[2002/02/21 11:15:44, 2] smbd/open.c:open_file(216)
  INSTALL opened file common/config/.root.passwords read=Yes write=No
[2002/02/21 11:15:44, 3] smbd/posix_acls.c:unpack_nt_owners(443)
  unpack_nt_owners: unable to validate owner sid.

Any ideas - Anyone?



-----Original Message-----
From: Mead, Tom 
Sent: 21 February 2002 10:35
To: 'David Mulcahy'
Cc: 'samba at lists.samba.org'
Subject: RE: Big problem with 2.2.X.

Thanks very much David - This seems to have done the trick.
This configuration option does not appear in SWAT.



-----Original Message-----
From: David Mulcahy [mailto:davmul at eseol.co.uk]On Behalf Of David
Sent: 20 February 2002 18:36
To: Mead, Tom
Cc: samba at lists.samba.org
Subject: Re: Big problem with 2.2.X.

Im no expert but i think you have to use  nt acl support = no on the share 
concerned in the smb.conf



I have been using samba 2.0.X for over a year with solaris 2.6 and windows
NT4. I have a windows application installed onto a Unix share which is
mapped to the NT clients using samba. Everything has worked perfectly with
the windows application untill i reciently tried upgrading to a 2.2.X
version of Samba. ( I have tried 2.2.2, 2.2.3, 2.2.3a).
Now when i try to start the windows application, it crashes when it fails to
read one of the applications configuration files on the share called
root.passwords. The server that i am testing this on is running Solaris 8,
and i have tested this with NT4 and windows 2000 clients.

More information about the samba mailing list