[Samba] smbprint & .config

Trevor Benson samba at a-1loans.com
Wed Feb 20 10:00:11 GMT 2002

I seem to have some issues coming to terms with the new smbprint configuration. Not that it is all that new, but I have worked on a ton of AIX Samba systems that are runing 1.9.x and the smbprint worked great in all aspects.  The box's couldn't be upgraded (or so said the company that did application builds related to Samba).  The printers were and are hosted from windows95 workstations and shared. I currently am running RedHat 7.2, and am using rpm's but have uninstalled and installed from source back and fourth to see if something was wrong with the install.  My main issue is I think I just dont understand the command line of smbprint script in Samba 2.2.1a compared the the script included in 1.9.x.  And I have seen 2 different explanations of the .config file.  Both explanations saying that field order matters. but both having different fields.  
#One was:

#Another was:

My /etc/printcap entry has evolved to this entry over time, and seeing a few different howto's and reading the doc's:


Main problem is once I create the .config with either of the preceding examples, then the smbprint file errors with:
: Not enough '\' characters in service

The format I have tried smbprint is 'smbprint host service username password </redirected input' which worked with the 1.9.x script, and still does.  So I am not sure if the .config file in each instance was incorrect, or the syntax of my command.  I also tried smbspool command and didn't seem to get that correct either.

If anyone who has this working is willing to shoot me an email, or point me at usage docs or an obvious mistake, then that would be great.  Thanks in advance for any assistance.  Please email to samba at a-1loans.com as well as the list.

-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list