[Samba] Big problem with 2.2.X.

Mead, Tom tmead at bci.it
Wed Feb 20 02:00:04 GMT 2002

I have been using samba 2.0.X for over a year with solaris 2.6 and windows
NT4. I have a windows application installed onto a Unix share which is
mapped to the NT clients using samba. Everything has worked perfectly with
the windows application untill i reciently tried upgrading to a 2.2.X
version of Samba. ( I have tried 2.2.2, 2.2.3, 2.2.3a).
Now when i try to start the windows application, it crashes when it fails to
read one of the applications configuration files on the share called
.root.passwords. The server that i am testing this on is running Solaris 8,
and i have tested this with NT4 and windows 2000 clients.

The following is the extract from the the smbd debug log  from when the
application is started -

[2002/02/14 17:49:21, 3] lib/util.c:unix_clean_name(387)
  unix_clean_name [/common/config/.root.passwords]
[2002/02/14 17:49:21, 3] smbd/dosmode.c:unix_mode(111)
  unix_mode(common/config/.root.passwords) returning 0644
[2002/02/14 17:49:21, 3] lib/util.c:unix_clean_name(387)
  unix_clean_name [common/config/.root.passwords]
[2002/02/14 17:49:21, 2] smbd/open.c:open_file(216)
  INSTALL opened file common/config/.root.passwords read=Yes write=No
[2002/02/14 17:49:21, 3] smbd/posix_acls.c:unpack_nt_owners(443)
  unpack_nt_owners: unable to validate owner sid.
[2002/02/14 17:49:21, 2] smbd/close.c:close_normal_file(212)
  kplus closed file common/config/.root.passwords (numopen=9)
[2002/02/14 17:49:21, 3] smbd/error.c:error_packet(91)
  error string = No such file or directory
[2002/02/14 17:49:21, 3] smbd/error.c:error_packet(103)
  error packet at smbd/nttrans.c(1399) cmd=160 (SMBnttrans)

I have no trouble opening the same file on the PC with notepad so it is not
a permission thing and it is visable from file manager or windows explorer.
I am using SECURITY = DOMAIN and user authentication is working OK.

This same problem was previously posted back in december with Samba 2.2.2
and the following reply was given: -

">On Thu, Dec 20, 2001 at 02:10:53AM +0800, anthony loupos wrote:
> Here's a strange issue: 
> I'm running winnt4 with Samba 2.2.2 on Solaris 2.8. Basically, a windows
app. has been installed onto a Samba share. The windows app has difficulties
accessing text files on the share. I notice that in log.smbd, I get an error
message (that corresponds to the file the app can't open). Here's a snippet
from the file:  
> [2001/12/19 12:32:23, 3] smbd/posix_acls.c:unpack_nt_owners(442) 
> unpack_nt_owners: unable to validate owner sid. 
This is a bug I fixed in 2.2 CVS, it should be fixed in 2.2.3. Check out the
CVS to be sure. Jeremy. "

Any feedback on this problem would be appreciated.

More information about the samba mailing list