[Samba] smbstatus connections.tdb not initialised

Steve steve at videogroup.com
Mon Feb 18 09:18:08 GMT 2002

Hi all,

I just figured out something that I could not find any solutions on any 
where, and thought I'd share it with you.

Initially I had a standard rpm install from the distribution for Samba 
(2.2.1a). A new fix version came out and since the rpm version was older I 
decided to switch to installing from src (2.2.2). 

Then in a weak moment I executed an online software upgrade, in automatic 
mode. When the users came in they complained that they could not login.

A quick review showed my mistake and I sorted all out. I thought...

Everything worked fine except that when I ran smbstatus it listed the shares 
and exited with "connections.tdb not initialised". 

Whereever I looked I could not find an answer to this failing command. I even 
reinstalled from src to no avail. Then by chance I was in the 
/usr/local/samba/bin dir and executed smbstatus from there and voila it 
showed all users, locks etc. A quick inspection showed that the rpm version 
executables had not been overwritten when I ran make install.

We have been using the daemons from 2.2.2 but apparently 2.2.1a utility pgms. 
(I'll change that too after hours as things have been running well for weeks 
and I don't know that it could not crash something switching.)

But I wanted to share this in case someone else end up having the same 
situation but cannot find the solution.
Steve Szmidt
V.P. Information
Video Group Distributors, Inc.

More information about the samba mailing list