[Samba] archive bit mapping problems with 2.2.3a

Gilbert, John jgilbert at eosbiotech.com
Wed Feb 13 18:21:07 GMT 2002

I've just tested the latest stable (2.2.3a) version of samba and see the
same problem I was having with the archive bit mapping as I had with 2.2.2. 

I sent in a bug report and two emails to this list but no feedback yet.
I'm pulling my hair out trying to get this fixed. Please help.

I am trying to do the following, new files get the archive bit set, and then
the user or account with appropriate permissions can turn the archive bit
The problem is that if you force the archive bit on through Unix permission
mapping (which does indeed map to the archive bit in NT space) and force
create mode,
you can't turn it off from NT space, and vice versa. If you change the
from Unix space, you can turn it back on with "attrib +a" but again you
turn it off (this shows that attrib is working correctly, it's a samba
thing). I'm
including the smb.conf in case there is some flag I'm missing. I've gone
through the smb.conf documentation and it seems that the alternate
section has been removed. Map archive is set to yes by default, so setting
it in SWAT
doesn't put it in smb.conf as it would be redundant (and setting it by hand
change this behavior). I've also tried setting dos filemode to yes, but I
haven't seen correct behavior with any combination I've tried. 

I'm using the "attrib -a filename" from a win2k machine to test this.
Please someone try this and let me know if it works for you. I have not
received any feedback from my previous emails.
It is important, as not being able to change the archive bit from NT space
breaks NT network backup systems. It's the last thing that needs to be fixed
before I can replace our $150k file servers with $5k Linux boxs.

Thanks in advance for your help.
John Gilbert
jgilbert at eosbiotech.com

        workgroup = NT_DOMAIN
        netbios name = EAGLE
        server string = Eagle Test Samba Server
        security = SERVER
        encrypt passwords = Yes
        allow trusted domains = No
        map to guest = Bad User
        password server = NT_SERV
        username map = /usr/local/samba/lib/smbusers
        log level = 1
        log file = /var/log/samba
        max log size = 100
        dns proxy = No
        alternate permissions = Yes
        force create mode = 0100
        hosts allow = 192.168.1.
        hosts deny = *
        dos filemode = Yes

        comment = Test Share
        path = /local/test
        read list = nobody
        read only = No
        guest ok = Yes

More information about the samba mailing list