[Samba] Compiling Samba on Solaris 8

Diego Julian Remolina dijuremo at hotmail.com
Wed Feb 13 15:34:02 GMT 2002

Hi again,

I posted a message some days ago and still have not gotten any reply.

Has anybody tried to compile samba-2.2.3a on Solaris 8 and came across a problem with the linker?

This is my configure line:
./configure --prefix=/usr/local/encap/samba-2.2.3a --with-automount
--with-quotas --with-utmp --with-profile --with-syslog --with-smbwrapper

Configure runs fine withouth any problems and then this is what I get from make:

Compiling tdb/spinlock.c with -fpic
Compiling tdb/tdbutil.c with -fpic
Compiling smbwrapper/wrapped.c with -fpic
Linking shared library bin/smbwrapper.so
ld: fatal: too many symbols require `small' PIC references:
        have 2057, maximum 2048 -- recompile some modules -K PIC.
collect2: ld returned 1 exit status
*** Error code 1
make: Fatal error: Command failed for target `bin/smbwrapper.so'

If I remove --with-smbwrapper  on the configure then everything works fine, I can make and make install.  We really need to use smbwrappers to make our server more secure.

I tried to change the option from -fPIC to -KPIC on the configure.in file but the result was that things would not compile.

Thanks for any help or clues you may give me as to how to fix this problem.

Diego Remolina
System Administrator
School of Mathematics
Georgia Institute of Technology

-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list