[Samba] smbmnt problem ...

Urban Widmark urban at teststation.com
Tue Feb 12 14:26:05 GMT 2002

On Tue, 12 Feb 2002, C.Lee Taylor wrote:

> 	Now, I downloaded the rpm from Samba.org for RedHat 7.2 and 
> installed it and I had the same problem.  I then recompiled 
> all the src rpms that I had for Samba since 2.2.1a.  All the 
> rpms from Samba.org had the same problem, I then 
> re-installed the one that came with RedHat 7.2 and it all 
> worked.  So I used the spec file form the src rpm ( with a 
> little work ) and made a basic Samba 2.2.3 with worked.

The samba spec file puts smbmnt in:

One fix would be to teach smbmount to also look in sbindir. You could try
the (untested) patch below on 2.2.3a and see if the samba rpms work then.


Index: source/client/smbmount.c
RCS file: /cvsroot/samba/source/client/smbmount.c,v
retrieving revision
diff -u -u -r1.30.4.14 smbmount.c
--- source/client/smbmount.c	19 Dec 2001 20:47:15 -0000
+++ source/client/smbmount.c	12 Feb 2002 22:18:34 -0000
@@ -479,6 +479,9 @@
 		if (file_exist(BINDIR "/smbmnt", NULL)) {
 			execv(BINDIR "/smbmnt", args);
 			fprintf(stderr,"execv of %s failed. Error was %s.", BINDIR "/smbmnt", strerror(errno));
+		} else if (file_exist(SBINDIR "/smbmnt", NULL)) {
+			execv(SBINDIR "/smbmnt", args);
+			fprintf(stderr,"execv of %s failed. Error was %s.", SBINDIR "/smbmnt", strerror(errno));
 		} else {
 			execvp("smbmnt", args);
 			fprintf(stderr,"execvp of smbmnt failed. Error was %s.", strerror(errno) );

More information about the samba mailing list