[Samba] smbmnt problem ...

C.Lee Taylor leet at leenx.co.za
Tue Feb 12 06:24:11 GMT 2002

	Thanks again for helping ...

Urban Widmark wrote:
> On Tue, 12 Feb 2002, C.Lee Taylor wrote:
> Do an strace on your mount commant (strace -f) and watch how smbmount
> fails to execvp("smbmnt", ...).
	I would do this, but I don't know how ...

> The path mount sets up for smbmount isn't necessarily the same as the one
> you have in your shell.
	Now this is what I think is the problem ...

> The quick fix is to get smbmnt into /usr/bin, the better fix is to fix the
> rpms (or one of the patches in the rpm?) to install smbmnt into BINDIR or
> to replace BINDIR with where it places smbmnt.
	Now, I downloaded the rpm from Samba.org for RedHat 7.2 and 
installed it and I had the same problem.  I then recompiled 
all the src rpms that I had for Samba since 2.2.1a.  All the 
rpms from Samba.org had the same problem, I then 
re-installed the one that came with RedHat 7.2 and it all 
worked.  So I used the spec file form the src rpm ( with a 
little work ) and made a basic Samba 2.2.3 with worked.

	So, where does this leave us.  I can get my system working, I 
will work on the spec file until I am happy that I will not 
have any problem, but I think that some will have to take a 
look at the spec file that ships with the tar and update it 
to use the right path ... I am not a programmer, and don't 
think that I will be able find the right solution, but I 
will help where I can ...

	Thanks again guys ...

Great product ...


More information about the samba mailing list